Consider variable naming strategy upfront

This is part of the Semicolon&Sons Code Diary - consisting of lessons learned on the job. You're in the workflows category.

Last Updated: 2024-04-19

During the building of the JavaScript calculators, I went back and forth about what the right variable names ought to be. Some of them were cashAmount other were businessAssetsAmount. I.e. every variable had amount appended.

In doing so, I learned that appending amount added little, except length.

Also, I really regret not instituting a clear division between HTML style names (cash_amount) and JavaScript style names (cashAmount), policed at some stable intersection.