Last Updated: 2021-05-16
Consider naming conventions not just for functions, but for every string (nay: every THING) in a project.
In a code base for Laravel (which uses camelCase for function names), I added
factories for test data. The
state attribute was a string and "since it wasn't a function" I
didn't think about making it consistent and therefore absent-mindedly went with snake
This inconsistency ended up being confusing. I should have paused when facing the need to add a space and weighed up the pros and cons of each way of doing it, then establishing a rule.